Grundsteuer Service Degredation

Incident Report for Taxy.io

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 08:00 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 30, 2026 - 07:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 07:13 CEST

Update

Grundsteuer outage acknowledged
Posted Jun 30, 2026 - 06:57 CEST

Investigating

Grundsteuer service outage
Posted Jun 30, 2026 - 06:46 CEST